Pb Afficheur Free DCC 2010

Auteur  
# 19/05/2012 à 10:35 Nicolas
Bonjour
Ulysse j'ai réalisé votre circuit free DCC 2010.
RAS avec la Com PC.
Le pilotage d'1 Loco foctionne avec RS 232.
Mais je n'ai pas d'affichage sur L'écran LCD (il s'agit d'un classique GTC-1601C + PCF 8574P)
Ras sur les pistes I2C (pas de cout circuit et autre)
Lorsque j'appuie longtemps sur 0 du clavier la centrale clignote rapidement , puis appui Long sur # repasse en clignotement lent --> la clavier semble fonctionner.
Avez vous une solution ?

Merci D'avance , Bravo pour votre réalisation .

Dans l'attente de votre réponse.
# 29/05/2012 à 18:43 Francois
Bonsoir,
J'ai réalisé une partie de la centrale d'Ulysse (booster + centrale + afficheur), et ait eu le même symptome que vous pour l'afficheur : clavier qui semble fonctionner, centrale qui fonctionne via RS232.
Après quelques tatonnements, je me suis aperçu d'une erreur de câblage (je n'ai pas réalisé de CI mais ai utilisé des plaques à trous) entre l'afficheur et le chip de commande PCF 8574 (de mémoire, mais plus très sûr, un pb de fils data ou de fils de commande). Un peu de fer à souder, et tout est rentré dans l'ordre ...
Btw, merci à Ulysse pour ses plans très astucieux pour réaliser un système DCC très économique !
PS : le schéma de booster marche bien mais je lui ai ajouté un petit disjoncteur électronique pour éviter les surchauffes inutiles en cas de court-circuit.
# 21/08/2012 à 18:50 nicolas
Bonjour ,
OK le problème DCC2010 est résolu car ayant réalisé moi mème avec TCI à partir des schémas présents dans le fichier DOC ( suite au problème de mise à l'échelle) j'ai pu constaté qu'il y a une erreur entre le schéma du fichier .DOC et le fichier TCI:
sur le fichier DOC la patte 4 de l'afficheur (E) est reliée sur le 11 du PCF 8574,alors que sur le TCI c'est la patte 12 du PCF. Il faut croiser la patte E et RS de l'afficheur et ouf ça marche . Ulysse je pense que vous pouvez corriger ce shéma dans votre prochaine version du fichier DOC. A Bientôt. Nicolas
# 12/06/2013 à 18:32 Deuff
Bonjour à tous,

J'ai réalisé la centrale qui dialogue avec le configurateur de CC. J'ai ensuite réalisé la console suivant le schéma de la doc (patte 4 de l'afficheur reliée a la patte 11 du PCF 8574 et patte 6 à 12) mais quand je connecte la console à la centrale, rien ne s'affiche, le clavier semble fonctionner car je peux passer la centrale en arrêt d'urgence (la LED clignote plus rapidement)... peut on tester la console sans être connecté à un réseau... au moin voir la version s'afficher...
jcd
# 13/06/2013 à 11:33 nicolas
Bonjour Deuff. Ayant eu le problème d'affichage je me suis rendu compte qu'il faut inverser les le E et RS de l'afficheur si tu as respecté le schéma fourni dans la DOC (Cf mon précédent post). Sans afficheur tu peu communiquer en RS232 avec le logiciel Dos transmis par Ulysse.
Il test la COM avec PIC et tu as la possibilité d'écrire et de lire dans le PIC.
# 13/06/2013 à 14:15 Deuff
Bonjour Nicolas et merci pour cette réponse rapide. j'insiste une nouvelle fois, c'est bien la patte 4 de l'afficheur qui est relié à la patte 11 du PCF 8574 et la patte 6 de l'afficheur à la patte 12 du PCF 8574! Une autre question, quand tu relies la console à la centrale seule, sans connection avec le réseau de train, l'afficheur "affiche" t'il quelque chose? La liaison RS232 fonctionne très bien, je lis et écris dans le PIC sans problème... merci et à bientôt... jcd
# 13/06/2013 à 19:05 nicolas
Oui. Sans être raccordé au réseau par défaut il affiche le message d'accueil . Puis si tu appuie sur le clavier pour arrêt d'urgence et que la LED clignote + vite , l'afficheur affiche "arret urgence".
A Bientôt
# 14/06/2013 à 12:58 Deuff
Bonjour Nicolas,mon circuit est donc bien conforme (j'ai vérifié le typon) et quand je le raccorde à la centrale rien ne s'affiche... j'ai même changé d'afficheur... même résultat... au niveau de la config de la centrale il y a peut être des paramètres à préciser...la seule CC que j'ai modifiée est la CC_16, j'ai mis 192 soit 11000000 pour adresse = 0000 et p=0 pour PCF8574... à bientôt jcd
# 14/06/2013 à 19:08 nicolas
Deuf, donc ton circuit fonctionne . Vérifie les diodes et un éventuel court circuit avec 1 patte coté afficheur. Je te rappel juste que moi mon afficheur ne fonctionnait pas car j'avais re-fait le circuit a partir du schéma sous TCI en respectant les numéros des pattes . Hors si tu regarde le tci fourmis par Ulysse 2 bornes de l'afficheur sont inversée. Désolé de revenir sur ce sujet mais j'ai passé du temps à voir la différence en faisant du fil à fil entre le TCI de Ulysse le mien et le schéma du fichier .doc. De mon coté je termine le pilotage des aiguillage + 4 potars (Ouf ça marche) je commence les entrées pour la détection des convois.
# 15/06/2013 à 19:57 Deuff
Bonsoir Nicolas et bonsoir à tous,
J'ai encore tout vérifié au niveau de mon circuit imprimé et j'ai même changé le PCF8574... et rien ne change... je me toune maintenant vers la configuration des CC car j'ai un doute concernant le choix des souris...si le problème est bien là ?... comment interprèter la doc d'Ulysse concernant les CC de 16 à 31... pouvez vous me préciser la valeur "type.type.type.num.num.num.num.num" et page suivante "valeur=32*type+numéro"
bonne soirée à vous...jcd
# 16/06/2013 à 11:33 nicolas
Bonjour Deuff.
Les CC ne change rien à l'afficheur LCD
Si tu appuie longtemps sur "0" l'afficheur affiche Arrêt d'urgence et puis appuie long sur "*" retour à l'écran précédent. Vérifie à l'oscillo que tu as des pulses D4,D5,D6,D7, R/W = 0 V , et des pulses sur E et R/S. vérifie qu'il n'y a pas un pont de soudure à l'ohmètre sur les 7 pattes, vérifie plusieurs fois le clavier avec la led en clignotement rapide sur ARU et clignotement lent sur la touche "*" long. le sens des 1N4148 . puis tu tu as tout testé tente d'inverser la patte 4 et 6 de l'afficheur.
Répondre à ce message
 
test

Créer un site gratuit avec e-monsite - Signaler un contenu illicite sur ce site

×